Juicer-install

From cslt Wiki
Revision as of 05:38, 5 February 2013 by Cslt (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

安装juicer1.0

1. 安装HTK-3.4.1

cd htk

./configure --prefix=/usr/local/

cd HTKLib

cp HGraf.null.c HGraf.c (for linux)

cd ..

sudo make

sudo make install


2. 安装torch3.0:

cd Torch3

cp ./config/Linux.cfg .

编辑./ Linux.cfg

  1. Packages you want to use

packages = distributions gradients kernels speech datasets decoder

如果系统是64位的话,则:

  1. Optimized double mode

opt_double = -Wall -O2 -ffast-math -mcpu=x86-64 -march=x86-64 -DUSE_DOUBLE

  1. Optimized float mode

opt_float = -Wall -O2 -ffast-math -mcpu=x86-64 -march=x86-64

如果build tracter的时候出现类似-fPIC的错误,在Linux.cfg中的compiler选项设置如下: compiler = g++ -fPIC

./xmake all

cd ..

3. 安装KissFFT130:

此步只需要解压工具包就可以,安装在下一步中

4. 安装tracter0.6.0: (tracter1.0安装失败退到0.6版)

cd tracter-0.6.0

生成Makefile:

执行aclocal && libtoolize && automake -a && autoconf

mkdir m4

./configure --with-kiss-fft=/data/app_data/dulinglu/software/kiss_fft130 --with-torch3=/data/app_data/dulinglu/software/Torch3 --with-htk-includes="-I/data/app_data/dulinglu/software/htk/HTKLib/" --with-htk-libs="/data/app_data/dulinglu/software/htk/HTKLib/HTKLib.a"

sudo make

sudo make install

cd ..

5. 安装juicer-1.0

a. 要保证PKG_CONFIG_PATH变量中包含tracter.pc

export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig

b. cd juicer-1.0

c. aclocal && libtoolize && automake -a && autoconf

d. mkdir m4

e. 配置

./configure --with-kiss-fft=/data/app_data/dulinglu/software/kiss_fft130 --with-htk-includes="-I/data/app_data/dulinglu/software/htk/HTKLib/" --with-htk-libs="/data/app_data/dulinglu/software/htk/HTKLib/HTKLib.a" --with-torch3=/data/app_data/dulinglu/software/Torch3

f. sudo make

g. sudo make install

h. cd ..

安装openfst1.3.3

1. cd openfst-1.3.3

2. ./configure --prefix=/usr/local/

3. sudo make

4. sudo make install

5. cd ..

更新.bashrc

JUTOOLS="/data/app_data/dulinglu/software/juicer-1.0/bin"

export JUTOOLS

exit后重新接入

安装ipp库 1. sudo vi /etc/ld.so.conf

2. 加入/data1/dulinglu/jucier_linux/ipp/sharedlib

3. sudo ldconfig –v 确认库被链接上